Mosquito d/l problems | DeeperBlue.com Forums
  Guest viewing is limited
  • Welcome to the DeeperBlue.com Forums, the largest online community dedicated to Freediving, Scuba Diving and Spearfishing. To gain full access to the DeeperBlue.com Forums you must register for a free account. As a registered member you will be able to:

    • Join over 44,280+ fellow diving enthusiasts from around the world on this forum
    • Participate in and browse from over 516,210+ posts.
    • Communicate privately with other divers from around the world.
    • Post your own photos or view from 7,441+ user submitted images.
    • All this and much more...

    You can gain access to all this absolutely free when you register for an account, so sign up today!

Mosquito d/l problems

Thread Status: Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.

damo

New Member
Feb 20, 2002
3
0
0
44
Hi,
I was just wondering if anyone else has had problems downloading the data from their Suunto Mosquito to a PC?

the software and connection lead I have are working fine as far as I can tell, as I can download my Wifes Stinger data no problem.

Are there any tricks I should be trying?

thanks for any help provided,
Damo
 

bdurrett

Colorado Transplant
Sep 19, 2002
1,383
255
0
57
Mosquito D/l

I haven't had any problems at all. What kind of problems are you looking at? If you can d/l your lady's Stinger, is there something on the connector of your Mosquito? Are the com parameters the same for the Mosquito as for the Stinger? I woud look at that and maybe having a different directory for the Mosquito data... Just a couple of ideas. So far, I have d/l'd my Mosquito to my PC and my laptop without problems
Good Luck!:confused
 

damo

New Member
Feb 20, 2002
3
0
0
44
yeah, it's very weird that it works for the Stinger and not the Mozzie. It has never worked with it either, even before we bought the stinger. Apparently the connection and settings should be the same for both with just the initial download option int eh software being different.

the problem is that it doesn't seem to be connecting up to the PC. I'll put both the dive computer and laptop it in transfer mode then attach the mozzie to the cradle thingy but it doesn't ever change display to verify that it's connected. I've moved the dive computer around trying to get a proper touch on the connectors etc but to no avail.

obviously this isn't a common problem so there might not be many people who can help ... I might see if I can contact Suunto to check theres nothing I'm doing wrong.

Cheers for your help mate,
Damo
 

bdurrett

Colorado Transplant
Sep 19, 2002
1,383
255
0
57
Skeeter d/l

Hey, something you just mentioned (or didn't actually) made me think....

What kind of cradle are you using? Is it the serial cradle with the DB-9 on it that connects to the COM 1 port of the PC or are you using a USB rig? If it is the USB rig, are you connecting it to a USB Hub? You might get a clue if the things are talking from the Hub indications (green/red/no LED) ....

Does the Stinger use the same cradle? (Shows ya how much I know 'bout the Stinger - nothing! :eek:

If they attach identically and the Mosquito does NOT see that it is connected but the Stinger does, I would guess that the Mos has a bad connector pin (maybe broken). If they use different cradles, maybe the cradle has a bent pin in the connector (if you are using the serial connector). :confused:

When I d/l mine, I attach the Skeeter to the cradle and THEN put it into transfer mode.... Could be that the Mos and the PC just can't sync to each other although that seems kinda stupid, especially if it is the standard COM port. What O/S are you using? Do the Mos and the Stinger use the same software? If so, then that is NOT the problem since the Stinger works.....

I am a computer system engineer that specializes in computer comms so this problem has got my ears up! Let me know what you find out!

Bret
 

jknights

New Member
Oct 27, 2002
1
1
0
66
Are you using the purchased Suunto interface or the one you can build yourself from here:
http://www.geocities.com/scubadiver_roli/english.html

I made this interface up and it works for my girlfriend's Musquito. Others have managed to get it to work for Vyper, Mosquito, etc.

To debug try this:
Connect DiveComputer and Interface. Using SDM start Transfer.

If you get an error message "Transfer of the profile memory timed out. Ensure that your dive computer is in its transfer mode, clean the contacts and try again."
This implies that he interface and the dive computer are not linked.

Else if you test the interface with the PC Interface setup function and it fails, saying that no interface was detected, then this implies that the electronics interface is not working i.e. you have a problem with your COM port or the interface electronics.

I made a similar interface for my Aladin and that also works well.
 
Last edited:
  • Like
Reactions: Pekka
DeeperBlue.com - The Worlds Largest Community Dedicated To Freediving, Scuba Diving and Spearfishing

ABOUT US

ISSN 1469-865X | Copyright © 1996 - 2021 deeperblue.net limited.

DeeperBlue.com is the World's Largest Community dedicated to Freediving, Scuba Diving, Spearfishing and Diving Travel.

We've been dedicated to bringing you the freshest news, features and discussions from around the underwater world since 1996.

ADVERT